XML collector issues in Horizon 24.1.1

Hello,

I’m facing an issue with displaying discovered resources for particular node for which I configured XML collector. Configuration seems to be fine, data is being stored in RRD files, but discovered resource types are not visible in GUI for a node. To be precise, graphs are defined. The thing is I can’t select any resources from node’s “Resource Graphs” page as they do not appear there. However, they are present in /opt/opennms/share/rrd/// folder. Also data is being collected and stored there in RRD files.

Could you please support me on the issue?

Kind regards,
Mateusz Kalisiak

The first step having the RRD files created is a good sign. To help you with creating the RRD templates the following bits would help us investigate:

  • exact location of the RRD files and the exact filename
  • snippet from the XML data collection group you try to graph with the collected objects
  • your current graph properties file which should work but doesn’t :slight_smile:

Hello,

thank you or responding. Please find attached a set of requested files.

Additionally, I provided you sample output of data we’re collecting.

Thank you for your help in advance.

Pozdrawiam/Regards,

Mateusz Kalisiak

604 640 710

www.hatomi.pl

(Attachment JSON_collector_config.zip is missing)

Can you please use a paste service for configuration file snippets and delete the last comment? It pretty much wastes reading the whole history of this issue. If you don’t know some, you can find some here: https://toolbox.opennms.eu. Left hand side in the menu “Paste”. Just add the links here in the comments with the config file snippets.

(post withdrawn by author, will be automatically deleted in 24 hours unless flagged)

My posts were flagged as they contain links. As per system message they supposed to be unhidden after 10 minuts, but I think they’re still invisible. How to fix that? Sorry for such questions, never used this tool before.

Here is requested data: https://paste.ee/p/jb4BN

I got it, your post was flagged as spam. I was able to flag this post as “Not Spam” and restored it here. You should be fine now. Thanks for adding the config snippets. I’ll take a look.