Upgrade Drools to version 7

Abstract

Drools 6.x has memory leak problems.

Folks

Technology

  • Drools

OpenNMS Components

  • Correlation Engine

Getting Started

  • Upgrade the integrated Drools to at least 7.6.0

Summary

  • The embedded Drools was upgraded from 6.5.0.Final to 7.7.0.Final. Some additional KIE dependencies were added, and the xstream library was updated to support them.

This was completed during Dev-Jam 2018.