Unable to enable kafka.service

After running the command: systemctl enable kafka
I receive the following error:
Synchronizing state of kafka.service with SysV service script with /lib/systemd/systemd-sysv-install.
Executing: /lib/systemd/systemd-sysv-install enable kafka
update-rc.d: error: kafka Default-Start contains no runlevels, aborting.

I can start kafka manually but the service will not enable. If you need to know configuration settings, let me know, otherwise my service files for zookeeper and kafka reflect what’s online…zookeeper.service starts on boot just fine.

it appears systemd is trying to enable a sysv service. Are you sure you have a kafka.service file somewhere that systemd can find it?

“otherwise my service files for zookeeper and kafka reflect what’s online” - YES I have a kafka.service file.

After removing the kafka file from the init.d directory I was able to ‘enable’ kafka. Reference Working on starting services, in the order that they need to activate, to properly start and run.