Unable to correct problems, you have held broken packages

Problem:
I am trying to install OpenNMS Horizon 27.1.1 and I am getting broken package errors.
I have tried some methods to fix it:

apt-get -y -o Debug::pkgProblemResolver=yes install opennms

But I still get the same error.

OpenNMS version: 27.1.1

Other relevant data:

Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 opennms-db : Depends: iplike-pgsql13 but it is not installable or
                       iplike-pgsql12 but it is not installable or
                       iplike-pgsql11 but it is not installable or
                       iplike-pgsql10 but it is not installable
E: Unable to correct problems, you have held broken packages.

Which version of PostgreSQL do you have installed? Iā€™m guessing Postgres is either not installed or there is an older version.