Topology Maps problem

Hello everyone,

I recently installed Opennms and I have several questions / problems regarding the tools

Problem:
I installed Opennms in order to automatically have a mqp representing the company’s network. The automatic discovery of the network is carried out without problem, but when I look at the maps given in result a lot of hosts are missing

Moreover some hosts have this errors :
Macs/ip addresses on Segment without node

Expected outcome:
I would simply like to have a complete map of my network automatically

Like that :

(i can put only one picture on this topic)

besides I don’t have an SVG tab in “Maps” is this normal?

OpenNMS version:
Version: 27.0.2

it is certainly not an error but more a bad handling / configuration on my part and I can not solve this “problem”.

Sorry if the question may seem “stupid”, I’m a beginner on this tool.

Thank you in advance for your help, if I forgot some information that could be for you useful tell me.

Hello,

I’ve the same problem anyone has the solution ?

Hi,

try to disable use-bridge-discovery in file(for linux):
/opt/opennms/etc/enlinkd-configuration.xml
example:

<enlinkd-configuration threads="5"
                     initial_sleep_time="60000"
                     rescan_interval="86400000"
                     use-cdp-discovery="true"
                     use-bridge-discovery="false"
                     use-lldp-discovery="true"
                     use-ospf-discovery="false"
                     use-isis-discovery="false"
                     topology_interval="30000"
                     bridge_topology_interval="300000"
                     max_bft="100"
                     discovery-bridge-threads="1"
                     />

and reload daemon Enlinkd:
cd /opt/opennms/bin/
./send-event.pl uei.opennms.org/internal/reloadDaemonConfig --parm ‘daemonName Enlinkd’

after few minutes you should see only nodes

Nope, that’s not how it works. If it’s already discovered those links via bridge-mib, they will persist in the topology unless you manually remove them. Disabling the discovery method will not remove the links.

@dino2gnt

I am not a specialist, but in my case it solved the problem. Maybe detected bridge links have a “lease” time after which they are removed.

Maybe! Wouldn’t be the first time I’ve been wrong about something. :slight_smile: