OpenNMS WMI configuration for data collectionwmi

I am trying to configure WMI data collector for nodes in OpenNMS. Wmi collection is working for computer where OpenNMS is installed, and i have default graphs and WMI service is register using created local admin account. But its not working for any node.

WMI is configured following: https://wiki.opennms.org/wiki/WmiConfiguration For data collection, i have created local admin account(we cannot use domain admin becauce of security, so our IT admins said), configured following: https://www.manageengine.com/network-monitoring/faq/configure-non-admin-user-for-wmi-monitoring.html

This is configuration in poller-configuration.xml

 <service name="WMI" interval="300000" user-defined="false" status="on">
         <parameter key="retry" value="2" />
         <parameter key="timeout" value="30000" />
        <parameter key="matchType" value="all"/>
         <parameter key="wmiClass" value="Win32_ComputerSystem" />
         <parameter key="wmiObject" value="Status" />
         <parameter key="compareOp" value="EQ" />
         <parameter key="compareValue" value="OK" />
         <parameter key="service-name" value="WMI" />
      </service>
 <monitor service="WMI" class-name="org.opennms.netmgt.poller.monitors.WmiMonitor" />

In wmi-config.xml i use local admin account for wmi collection, and for accessing remote mashines their domain admin account:

<wmi-config xmlns="http://xmlns.opennms.org/xsd/config/wmi" timeout="1500" retry="2" username="localadmin" domain="machinename" password="pass">
     <!-- This definition shows how to specify a user for a specific IP address -->
     <definition  username="domainaccount" domain="domain" password="pass">
        <specific xmlns="">xx.xx.xx.xx</specific>
     </definition>
</wmi-config>

Local admin account is configured on remote machine as on opennms machine.
When i test wmi using wbemtest.exe for a remote node connection works perfect and i can browse all classes, get hostname…etc…

Only problem is that OpenNMS cannot find WMI on node as enabled so collection doesnot work.
As I said, WMI works only for machine where OpenNMS is installed.

Is it possible to use local admin account for this? maybe that is the main problem…

It is suggested to use WinRM/WSMAN for collection instead of WMI.
See the article at WinRM in OpenNMS for details.