OpenNMS Horizon install failed with CentOS Stream 9

Hi all

Trying to install latest ONMS Horizon on CentOS 9 in a VM.
VMware thinks the OS is version 5 or earlier, the same, I suppose, of the ONMS installation script, infact the startup script is using the not more present /etc/init.d directory in order to start ONMS …
I started ONMS directly with sudo -u opennms /opt/opennms/bin/opennms start … there is a solution for this in order to use systemctl to start it ?

Thanks

Hello and welcome to our community. Do you mean CentOS 8 stream? I’m not aware of a CentOS 9 version exists? What installation instructions have you followed? We highly recommend the ones from our official documentation you can find here: Installation and configuration

Thanks Indigo

Yes, version 9 exist
https://centos.org/download/

I have followed the installation instructions from here
https://docs.opennms.com/horizon/29.0.1/deployment/core/getting-started.html

I suppose that the cause of the problem init.d instead of systemctl is the version 9 that is confused with early version.

Was able to reproduce the problem. Our systemd unit calls the init.d start script. I’ve documented the bug here in [NMS-13783] Systemd startup uses legacy SysV init script - The OpenNMS Issue Tracker

I was able to get the systemd unit to work by changing the path.

Edit the systemd unit:

sudo vi /etc/systemd/system/multi-user.target.wants/opennms.service

Set the path to

ExecStart=/opt/opennms/bin/opennms -s start
ExecStop=/opt/opennms/bin/opennms stop

Reload systemd

sudo systemctl daemon-reload

Should now be able to enable the service on system boot and start the service with

sudo systemctl enable --now opennms

Hope this helps.

1 Like

Many Thanks Indigo

I will try your Workaround and I will let you know asap.

Ciao

Hi Indigo

Workaround OK

Thanks

Ciao

1 Like

Ciao Indigo

May be is important to know that SELINUX must be disabled (default enabled on CentOS 9) otherwise the Discovery Scan does not work …
May be in permissive mode is the same but I have not tried.

Ciao

1 Like

As far as I am aware, we have no support for running with SELinux enabled.

We also have zero testing to date running on CentOS 9 Stream. :slight_smile:

Thanks Indigo

It was only to inform other people of this “strange behavior”.

Ciao