Opennms-amqp-event-receiver Exception

Hello,

Following the instructions for Event Receiver AMQP setup leads to the following exception in camel-jms.
I can see the tcp connection in rabitmq logs form openNMS but no message is consumed. I added bundle:requirements camel-jms output for reference. The problem was observed in openNMS horizont 23.0.3 but it can be also replicated in version 22.0.4 and 24.0.0

Exception in thread "Camel (amqpEventReceiverCamelContext) thread #30 - JmsConsumer[opennms-events]" java.lang.LinkageError: org/apache/commons/logging/Log
        at org.apache.camel.component.jms.DefaultJmsMessageListenerContainer.runningAllowed(DefaultJmsMessageListenerContainer.java:76)
        at org.springframework.jms.listener.AbstractJmsListeningContainer.isRunning(AbstractJmsListeningContainer.java:348)
        at org.springframework.jms.listener.DefaultMessageListenerContainer$AsyncMessageListenerInvoker.run(DefaultMessageListenerContainer.java:1107)
        at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149)
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624)
        at java.lang.Thread.run(Thread.java:748)

bundle:requirements camel-jms
org.apache.camel.camel-jms [117] requires:
------------------------------------------
osgi.wiring.package; (&(osgi.wiring.package=org.apache.camel)(version>=2.19.0)(!(version>=2.20.0))) resolved by:
   osgi.wiring.package; org.apache.camel 2.19.1 from org.apache.camel.camel-core [114]
osgi.wiring.package; (&(osgi.wiring.package=org.apache.camel.api.management)(version>=2.19.0)(!(version>=2.20.0))) resolved by:
   osgi.wiring.package; org.apache.camel.api.management 2.19.1 from org.apache.camel.camel-core [114]
osgi.wiring.package; (&(osgi.wiring.package=org.apache.camel.impl)(version>=2.19.0)(!(version>=2.20.0))) resolved by:
   osgi.wiring.package; org.apache.camel.impl 2.19.1 from org.apache.camel.camel-core [114]
osgi.wiring.package; (&(osgi.wiring.package=org.apache.camel.spi)(version>=2.19.0)(!(version>=2.20.0))) resolved by:
   osgi.wiring.package; org.apache.camel.spi 2.19.1 from org.apache.camel.camel-core [114]
osgi.wiring.package; (&(osgi.wiring.package=org.apache.camel.support)(version>=2.19.0)(!(version>=2.20.0))) resolved by:
   osgi.wiring.package; org.apache.camel.support 2.19.1 from org.apache.camel.camel-core [114]
osgi.wiring.package; (&(osgi.wiring.package=org.apache.camel.util)(version>=2.19.0)(!(version>=2.20.0))) resolved by:
   osgi.wiring.package; org.apache.camel.util 2.19.1 from org.apache.camel.camel-core [114]
osgi.wiring.package; (&(osgi.wiring.package=org.apache.camel.util.concurrent)(version>=2.19.0)(!(version>=2.20.0))) resolved by:
   osgi.wiring.package; org.apache.camel.util.concurrent 2.19.1 from org.apache.camel.camel-core [114]
osgi.wiring.package; (&(osgi.wiring.package=org.springframework.beans)(version>=4.1.0)(!(version>=5.0.0))) resolved by:
   osgi.wiring.package; org.springframework.beans 4.2.9.RELEASE_1 from org.apache.felix.framework [0]
osgi.wiring.package; (&(osgi.wiring.package=org.springframework.context)(version>=4.1.0)(!(version>=5.0.0))) resolved by:
   osgi.wiring.package; org.springframework.context 4.2.9.RELEASE_1 from org.apache.felix.framework [0]
osgi.wiring.package; (&(osgi.wiring.package=org.springframework.core.task)(version>=4.1.0)(!(version>=5.0.0))) resolved by:
   osgi.wiring.package; org.springframework.core.task 4.2.9.RELEASE_1 from org.apache.felix.framework [0]
osgi.wiring.package; (&(osgi.wiring.package=org.springframework.jms)(version>=4.1.0)(!(version>=5.0.0))) resolved by:
   osgi.wiring.package; org.springframework.jms 4.2.9.RELEASE_1 from org.apache.felix.framework [0]
osgi.wiring.package; (&(osgi.wiring.package=org.springframework.jms.connection)(version>=4.1.0)(!(version>=5.0.0))) resolved by:
   osgi.wiring.package; org.springframework.jms.connection 4.2.9.RELEASE_1 from org.apache.felix.framework [0]
osgi.wiring.package; (&(osgi.wiring.package=org.springframework.jms.core)(version>=4.1.0)(!(version>=5.0.0))) resolved by:
   osgi.wiring.package; org.springframework.jms.core 4.2.9.RELEASE_1 from org.apache.felix.framework [0]
osgi.wiring.package; (&(osgi.wiring.package=org.springframework.jms.listener)(version>=4.1.0)(!(version>=5.0.0))) resolved by:
   osgi.wiring.package; org.springframework.jms.listener 4.2.9.RELEASE_1 from org.apache.felix.framework [0]
osgi.wiring.package; (&(osgi.wiring.package=org.springframework.jms.support)(version>=4.1.0)(!(version>=5.0.0))) resolved by:
   osgi.wiring.package; org.springframework.jms.support 4.2.9.RELEASE_1 from org.apache.felix.framework [0]
osgi.wiring.package; (&(osgi.wiring.package=org.springframework.jms.support.converter)(version>=4.1.0)(!(version>=5.0.0))) resolved by:
   osgi.wiring.package; org.springframework.jms.support.converter 4.2.9.RELEASE_1 from org.apache.felix.framework [0]
osgi.wiring.package; (&(osgi.wiring.package=org.springframework.jms.support.destination)(version>=4.1.0)(!(version>=5.0.0))) resolved by:
   osgi.wiring.package; org.springframework.jms.support.destination 4.2.9.RELEASE_1 from org.apache.felix.framework [0]
osgi.wiring.package; (&(osgi.wiring.package=org.springframework.scheduling.concurrent)(version>=4.1.0)(!(version>=5.0.0))) resolved by:
   osgi.wiring.package; org.springframework.scheduling.concurrent 4.2.9.RELEASE_1 from org.apache.felix.framework [0]
osgi.wiring.package; (&(osgi.wiring.package=org.springframework.transaction)(version>=4.1.0)(!(version>=5.0.0))) resolved by:
   osgi.wiring.package; org.springframework.transaction 4.2.9.RELEASE_1 from org.apache.felix.framework [0]
osgi.wiring.package; (&(osgi.wiring.package=org.springframework.util)(version>=4.1.0)(!(version>=5.0.0))) resolved by:
   osgi.wiring.package; org.springframework.util 4.2.9.RELEASE_1 from org.apache.felix.framework [0]
osgi.wiring.package; (&(osgi.wiring.package=org.apache.commons.logging)(version>=1.1.0)(!(version>=2.0.0))) resolved by:
   osgi.wiring.package; org.apache.commons.logging 1.2.0 from org.ops4j.pax.logging.pax-logging-api [6]
osgi.wiring.package; (&(osgi.wiring.package=org.slf4j)(version>=1.7.0)(!(version>=2.0.0))) resolved by:
   osgi.wiring.package; org.slf4j 1.7.25 from org.ops4j.pax.logging.pax-logging-api [6]
osgi.wiring.package; (&(osgi.wiring.package=javax.jms)(version>=1.1.0)(!(version>=3.0.0))) resolved by:
   osgi.wiring.package; javax.jms 1.1.0 from org.apache.felix.framework [0]
osgi.wiring.package; (osgi.wiring.package=org.w3c.dom) resolved by:
   osgi.wiring.package; org.w3c.dom 0.0.0 from org.apache.felix.framework [0]
osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.5.0)(!(version>=2.0.0))) resolved by:
   osgi.wiring.package; org.osgi.framework 1.8.0 from org.apache.felix.framework [0]
osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework.wiring)(version>=1.0.0)(!(version>=2.0.0))) resolved by:
   osgi.wiring.package; org.osgi.framework.wiring 1.2.0 from org.apache.felix.framework [0]
osgi.ee; (&(osgi.ee=JavaSE)(version=1.8)) resolved by:
   osgi.ee; JavaSE [1.0.0, 1.1.0, 1.2.0, 1.3.0, 1.4.0, 1.5.0, 1.6.0, 1.7.0, 1.8.0] from org.apache.felix.framework [0]

I’m having the exact same problem. Did you solve this?