Opennms 24.1.0 from scratch on Ubuntu 19.04 won't install

opennms 24.1.0-1 depends from opennms-db (=24.1.0-1)
which depends from postgresql (various versions from 9.1 to 10)
but Ubuntu 19.04 provides Postgresql 11 and opennms installation is blocked

This looks to me like a bug in the Debian packages. OpenNMS can be installed with PostgreSQL 11. Can you please open a bug in our issue tracker about this problem?

I had the same impression, the explicit dependency
in the .deb misses the version 11 (but it’s a true incompatibility or simply the packager forgot to insert version 11 ?)

Issue NMS-12121

1 Like