Minion complains about JAVA_HOME

Hi!

Do i need to specify the java home path in the conf-file?

Debian 9 stretch

cat /etc/default/minion 
# OpenNMS Sentinel Startup Configuration

# the user to run as
# export RUNAS=minion

# minimum amount of memory for the Karaf container to allocate
# export JAVA_MIN_MEM=128M

# maximum amount of memory for the Karaf container to allocate
# export JAVA_MAX_MEM=512M

# maximum number of file descriptors to allocate
# export MAX_FD=maximum

# the root directory of the Java enviroment
from this:  # export JAVA_HOME=
to this: export JAVA_HOME=/usr/lib/jvm/java-11-openjdk-amd64

# the path to the Java executable (defaults to $JAVA_HOME/bin/java)
# export JAVA=

# debugging options to pass to Java on startup
# if set, these will REPLACE the default options shown here
# export JAVA_DEBUG_OPTS="-agentlib:jdwp=transport=dt_socket,server=y,suspend=n,address=${JAVA_DEBUG_PORT}"

# the port to use when debugging Java
# export JAVA_DEBUG_PORT=5005

# other options to pass to Java on startup
# export JAVA_OPTS="-Xms${JAVA_MIN_MEM} -Xmx${JAVA_MAX_MEM} -XX:+UnlockDiagnosticVMOptions"

# extra libraries or paths to add to the Java class path
# export CLASSPATH=

# uncomment to enable debugging in the Karaf container
# export KARAF_DEBUG=TRUE

# additional locations to look for native libraries
# export LD_LIBRARY_PATH=

# set to "TRUE" if failing to configure userspace ping should be fatal
# export PING_REQUIRED=TRUE

opennms ver 26.1.0

What Linux distribution and version you are running? It would help us to reproduce your problem. By default, it shouldn’t complain, and would be interested if this is an RPM/DEB packaging bug.

I exported the javahome in linux manually. Somehow the java startupscript didnt work