ICMP polling is not working on OpenNMS Horizon 29.0.2

I have a new version of OpenNMS Horizon 29.0.2 installed on Red Hat Enterprise Linux release 8.4, and for the most part it is working, however when adding a new device, I notice that ICMP is not reporting.

when logging into karaf and tring ping, I am getting the following error (IP Address removed for obfuscation)
PING: /x.x.x.x java.lang.UnsupportedOperationException

I followed this link - OpenNMS can't reach devices with ICMP but works with ping on the cli and have confirmed that JICMP and JICMP6 are installed and pathed correctly in the libraries.properties file.

what are the outputs of

sysctl net.ipv4.ping_group_range


id opennms


Output from sysctl net.ipv4.ping_group_range is
net.ipv4.ping_group_range = 10001 10001

output from id opennms
uid=989(opennms) gid=985(opennms) groups=985(opennms)

I have also tried setting the net.ipv4.ping_group_range to the following values (and restarting the server after each try)

net.ipv4.ping_group_range = 0 10001
net.ipv4.ping_group_range = 989 989
net.ipv4.ping_group_range = 985 985

I am still getting the same issue when pinging from karaf
OpenNMS (29.0.2) on Apache Karaf (4.3.2)

Hit ‘’ for a list of available commands
and ‘[cmd] --help’ for help on a specific command.
Hit ‘’ to exit this console.

admin@opennms()> ping
PING: / java.lang.UnsupportedOperationException

I’m trying to install a 29.0.4 horizon, and I’m getting similar results. If I add the device using a requisition, and specify the services (like SNMP, SSH and ICMP) all those services immediately show as down on the device. If I just enter the IP and no services and then poll the device, it only discovers SSH and SNMP, and then the services show as UP.

I looked at the other post noted as well, the one that advised you login as admin to itself using karaf. Exactly how is this done. I tried on my opennms server to ssh admin@localhost with the port specified (8101?) and was prompted for a password. I have no idea what the karaf password is. The default I found online was karaf, but that did not work. Either did no password.

I did however confirm that the jicmp and jcimp6 are loaded.


The admin password for the Karaf shell is the exact same as your admin user in the OpenNMS web user interface.

Can you please share the following information:

  • Exact OS version
  • Kernel version
  • systemd version

This jiives with pollerd’s behavior when the critical service (default ICMP) is down - it treats the entire node as down.

I did find this post, which worked for me. Seems to have righted the ship.

H29+ won’t start with permission error to open ICMP socket

With the end of CentOS8, I used Alma Linux (I think version 8.5) to create my new Horizon install. Not alot of direction out there. I’m hoping that Tarus, or someone produce another series of videos similar to OpenNMS 101 to cover how to install the newer versions maybe using Docker? Or at the very least updating the videos to cover some items like opennms has to run now from something other than root.


1 Like

So I was able to resolve this issue. We are installing onto a hosted REL8 server that is also being managed with SELinux. I found in the RedHat Customer Portal nonroot users are unable to ping, pointing to a corrupt or incorrect setting in iputils. I reinstalled iputils by running th following command to resolve this issue - sudo dnf reinstall iputils

1 Like