How to get rid of "Help Improve OpenNMS" message after loggin in?

Hello,

when I login into our OpenNMS, I have always the message
“Help Improve OpenNMS” … Opt-in … Opt-out

How can I get rid of this message by any definition-file ?

Thanks
Michael

If that popup keeps coming up after responding, that means the config file isn’t writing the response properly.

Make sure that the $OPENNMS_HOME/etc/org.opennms.features.datachoices.cfg file contains:

acknowledged-at=Sat Mar 20 10\:56\:08 EST 2018 
enabled=false 
acknowledged-by=admin

The acknowledged field can be any valid date - doesn’t have to be that specific day. If there are other settings in that file, they are fine to stay - you don’t have to overwrite, just make sure there is a value for these three fields.

1 Like