How do I tame collectd debug logging

Problem:
I’m trying to debug an snmp collector that is failing, but turning on DEBUG for collectd in log4j2.xml causes collectd to generate so much data that the log file is rolling at least once a minute

Expected outcome:
Im just wondering if there is a way to selectively enable debugging in collectd.log so that I only get debug level of output for a specific collection package.

OpenNMS version:
OpenNMS version 25.2.1

I think this here is a good approach to do it: Separate collectd log.

1 Like

That looks like it will do the trick. Will check it out on Monday. Thanks!