How can I disable heap dumps on a Minion

Hi!

Sometimes the minion-service crashes. We have tried to increase the heapSizeMEM. And it works better now. But a few days ago it crashed again. It creates a lot of heapdump-files, so the disk was filled.

How do i disable heapdump when running a minion?

ver. 26.1.0

Thanks!

In general it is helpful to have heap dumps on a Java crash. If you really want to get rid of them you can set the Java option -XX:HeapDumpPath=/dev/null.

1 Like

Thanks!

Is this correct? @indigo

other options to pass to Java on startup

export JAVA_OPTS="-Xms${JAVA_MIN_MEM} -Xmx${JAVA_MAX_MEM} -XX:+UnlockDiagnosticVMOptions"

to:
export JAVA_OPTS="-Xms${JAVA_MIN_MEM} -Xmx${JAVA_MAX_MEM} -XX:+UnlockDiagnosticVMOptions -XX:HeapDumpPath=/dev/null"

yes, this should do it if you run it on classic install, you can verify if the parameter is applied with ps aux | grep java

Thanks!