Horizon 24 install problem with OpenJDK 11 on Windows

installation
windows
#1

I’m trying to install OpenNMS Horizon 24 on Windows with OpenJDK 11 and am having trouble getting past step 3 of 10 where you need to specify the JDK path. I keep getting the error “The chosen directory does not contain the required product”.

I tried pointing it at every directory in the JDK tree from the top level on down and could not get past this.

I tried the following 3 JDK builds, all with the same result:
Amazon Corretto 11.0.3.7.1
AdoptOpenJDK HotSpot 11.0.3_7
Zulu 11.0.3

Anyone know what the installer is looking for or have this working on Windows?

Thanks
Dave

#2

That message is most common if you have selected a JRE instead of a JDK. Try using the Oracle JDK.

#3

I definitely selected OpenJDK 11 and not JRE. The 3 JDKs that I tried do not include a JRE. I’m wondering if that might have something to do with it.

I installed the Zulu 8 JDK build and compared it side by side with Zulu 11 JDK and one noticeable difference is Zulu 8 JDK includes a JRE. FWIW, Horizon 24 works fine with JDK 8, I just thought I’d give it a go with JDK 11, since the release notes say it’s supported on OpenJDK 11.

I have no interest in using the Oracle JDK.

Dave

#4

There are not a lot of users running OpenNMS on Windows, and I’m not one of them. V8 should keep working for now.

#5

Yes, I’m aware that Windows isn’t the preferred platform. FWIW, it does work pretty well on it.

I plan to switch my prod instances over to Linux sometime this summer and have been experimenting a bit running it on CentOS 7.

Thanks for taking a look.

Dave