Help setting up flows

Can you guide me in Flow Support

https://docs.opennms.com/horizon/28.1.0/operation/flows/setup.html#link-the-web-ui-to-helm

followed this step but icon is not appear on the top-right corner of a resource graph

@mmahacek

Are your devices sending flows to your OpenNMS server via a port and protocol that is enabled in telemetryd config and is allowed via the system’s firewall?

yeah i think.

image

@mmahacek

https://opennms.discourse.group/t/syslog-setup-questions/2174/43?u=nitin

Apart from that i need to add any other port ?

whether i have to add below url port for accessing the url?
http://grafana:3000/dashboard/flows?node=$nodeId&interface=$ifIndex
@mmahacek

Hi @mmahacek @moderators I have tried the grafana for flow support but i am not able to view in OpenNMS application under Resource Graphs.
Grafana version i am using 7.5.7. even though i have tried plugin options.

port enable and other process : Syslog setup questions - #43 ,

i am one the user of OpenNMS & grafana. When i install the Grafana 7.5.7 along with plugin in ubuntu server 18.04. we are not getting node and other data value in dashboard.
what we have to do for getting data in dashboard?

We are unable to fetch the data in Grafana dashboard. @mmahacek



Why we are using 127.0.0.1:9092 port ? whether its mandatory to add that port 9092 for fetch the data in grafana

If you aren’t using Kafka, you don’t need to set any of those options.

It doesn’t appear you even have the OpenNMS Grafana app configured to talk to OpenNMS.

Start here:
https://docs.opennms.com/horizon/28.1.0/operation/flows/setup.html

how to integrate OpenNMS with Grafana? @dino2gnt

https://docs.opennms.com/helm/7.1.2/installation/rpm.html

i required 127.0.0.1:9092 can i get link for this for installation. @dino2gnt

You aren’t running Kafka. You don’t need to configure anything related to Kafka. Kafka is not a requirement to process flows. Quit blinding copying and pasting things from the docs that you don’t understand.

it seen that u insulted me indirectly :stuck_out_tongue_closed_eyes:

@dino2gnt

If you were running Kafka, you would already have this information.

It sounds like you are working on a new install of OpenNMS, and are trying to setup a number of different features at once. I would suggest to focus on one at a time, so you can best learn how each work.

(Apache) Kafka is an alternative message broker system that can be used as a replacement for the embedded ActiveMQ service, and is typically used in larger deployments. We do not provide support here on installing or managing Kafka clusters.

Hi @mmahacek @dino2gnt

  1. We are able view the graph chart in Grafana but need to map the same graph in under Resource Graphs, where we have snmp data.
  2. We have gone through the document and we are able to fetch the data in Grafana.
  3. Same way we required grafana dashboard data in OpenNMS Application.

share me the procedure on this.

The flow data? It is only visible in Grafana via the Helm plugin and data sources.

Hi @mmahacek

Even we are expecting same result as per the attached video. simultaneously we can see in Grafana and OpenNMS.

That isn’t what is shown in the video. The graph in OpenNMS is SNMP data. Flow data is not visible in OpenNMS, only via Helm in Grafana.

Hi @dino2gnt @mmahacek

As per the snapshot and documentation they have mentioned icon will appear in resource graph in right corner after completing process. but still we are getting the same even though we have SNMP interface.

  1. in kafka ssh they have mentioned URL, In that what we have to mentioned same as it’s or OpenNMS ip address with grafana port 3000.

kindly update on this

We are able to listen required port but still not able fetch data in Flow Deep Dive | OpenNMS Helm
even though data source test is passed in (OpenNMS Flow, OpenNMS Entities, OpenNMS Performance)
Helm plugin version - 6.0.0
grafana ver - 7.5.5

Error
{
“request”: {
“server”: {
“id”: “cfd2288d18a3862763de0c7c14d0ad35”,
“name”: “OpenNMS Flow”,
“url”: “/api/datasources/proxy/1”,
“auth”: null,
“metadata”: {
“version”: {
“version”: “28.1.0”,
“dv”: “28.1.0”
},
“type”: {
“id”: 1,
“label”: “HORIZON”
},
“ticketerConfig”: {
“plugin”: null,
“enabled”: false
}
}
},
“params”: {
“N”: “10”,
“start”: “1634142584630”,
“end”: “1634228984630”,
“step”: “94323”,
“includeOther”: “true”
},
“method”: “GET”,
“url”: “api/datasources/proxy/1/rest/flows/applications/series”,
“hideFromInspector”: false,
“timeout”: 10000
},
“response”: {
“error”: “Internal Server Error”,
“response”: “Failed to execute query: java.lang.Exception: {“root_cause”:[{“type”:“parsing_exception”,“reason”:“Unknown aggregation type [proportional_sum]”,“line”:39,“col”:31}],“type”:“parsing_exception”,“reason”:“Unknown aggregation type [proportional_sum]”,“line”:39,“col”:31,“caused_by”:{“type”:“named_object_not_found_exception”,“reason”:”[39:31] unknown field [proportional_sum]"}}",
“message”: “Failed to execute query: java.lang.Exception: {“root_cause”:[{“type”:“parsing_exception”,“reason”:“Unknown aggregation type [proportional_sum]”,“line”:39,“col”:31}],“type”:“parsing_exception”,“reason”:“Unknown aggregation type [proportional_sum]”,“line”:39,“col”:31,“caused_by”:{“type”:“named_object_not_found_exception”,“reason”:”[39:31] unknown field [proportional_sum]"}}"
}
}

@mmahacek @dino2gnt