Elasticsearch circuit breaker exception in Flow Deep Dive Dashboard

Problem

When you open the Flow Deep Dive tool you get the following exception:

Failed to execute query: java.lang.Exception: {"root_cause":[{"type":"circuit_breaking_exception","reason":"[parent] Data too large, data for [<http_request>] would be [1026529358/978.9mb], which is larger than the limit of [986061209/940.3mb], real usage: [1026526448/978.9mb], new bytes reserved: [2910/2.8kb], usages [request=72/72b, fielddata=1486149/1.4mb, in_flight_requests=2910/2.8kb, accounting=38321284/36.5mb]","bytes_wanted":1026529358,"bytes_limit":986061209,"durability":"PERMANENT"}],"type":"circuit_breaking_exception","reason":"[parent] Data too large, data for [<http_request>] would be [1026529358/978.9mb], which is larger than the limit of [986061209/940.3mb], real usage: [1026526448/978.9mb], new bytes reserved: [2910/2.8kb], usages [request=72/72b, fielddata=1486149/1.4mb, in_flight_requests=2910/2.8kb, accounting=38321284/36.5mb]","bytes_wanted":1026529358,"bytes_limit":986061209,"durability":"PERMANENT"}

Solution

I’ve solved this problem by tweaking the garbage collection and memory management settings in Elasticsearch with the following ES_JAVA_OPTIONS settings:

environment:
  - "ES_JAVA_OPTS=-XX:G1ReservePercent=25 -XX:InitiatingHeapOccupancyPercent=30"
1 Like