Adding new service to requisition - node does not recognize

Hi!

we’re using in our Requisition the Class org.opennms.netmgt.provision.detector.snmp.Win32ServiceDetector for example:

Windows Admin Center org.opennms.netmgt.provision.detector.snmp.Win32ServiceDetector win32ServiceName : Windows Admin Center

Our poller-configuration.xml looks like this:

<service name="Windows Admin Center" interval="300000" user-defined="false" status="on">
  <parameter key="retry" value="6"/>
  <parameter key="timeout" value="4950"/>
  <parameter key="port" value="161"/>
  <parameter key="service-name" value="Windows Admin Center"/>
</service>

This worked as expected for years. Now, with the version 24.1.3 we added the Windows Admin Center as a service, but the node did not recognize the service (tried rescan and restart)

Are we doing something wrong?

Hmm,

today the service was discovered. I don’t know what was wrong.

Everything is fine now.

There are times when i add a new detector, and it doesnt appear to be working. I leave it and come back 24hrs later to find that it has worked overnight.

I wonder if there is something different happening during the scheduled discovery that doesnt happen when you rescan or restart. Ot maybe we’re just too impatient :slight_smile: